База знаний

  • Бухгалтерский учёт

Расчет Налога на имущество

Отчет представляет собой расшифровку показателей регламентированного отчета 1С по налогу на имущество, и позволяет понять какие "Основные средства" попали в базу для налога, а какие нет.

ВАЖНО: Отчет работает в конфигурациях не использующих "Управляемые формы" (Бухгалтерия 2.0 и другие).

Расшифровка налога на имущество


скачать Скачать отчёт

	Функция POSTзапрос(Запрос)

        //ЗаписьЖурналаРегистрации("Запрос HTTP",,,,)

        Код = Запрос.ПараметрыЗапроса["test"];
        Отбор = Код <> "NULL";

        Джейсон = НОвый ЗаписьJSON;
        Джейсон.УстановитьСтроку(Новый ПараметрыЗаписиJSON(,Символы.Таб));
        Выборка = Справочники.Контрагенты.Выбрать();

        Массив = Новый Массив;


        Пока Выборка.Следующий() Цикл
                Если Отбор и НЕ Выборка.Код = Код Тогда
                        Продолжить;
                КонецЕсли;
                ОтветСтр =  Новый Структура("Наименование,Код,УИД", Выборка.Наименование,Выборка.Код,XMLСтрока(Выборка.Ссылка.УникальныйИдентификатор()));
                Массив.Добавить(ОтветСтр);
        КонецЦикла;

        ЗаписатьJSON(Джейсон,Массив);
        СтрокаДжейсон = Джейсон.Закрыть();

        Ответ = Новый HTTPСервисОтвет(200);
        Ответ.УстановитьТелоИзСтроки(СтрокаДжейсон,КодировкаТекста.ANSI,ИспользованиеByteOrderMark.НеИспользовать);
        Возврат Ответ;
КонецФункции

08.07.2015